+ Reply to Thread
Results 1 to 3 of 3

Thread: Question - PHP.ini memory limit

  1. #1
    dchicago is offline New Bee
    Join Date
    May 2007
    Posts
    2
    WHB Points this Month
    0.00
    WHB Points
    0.00
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Default Question - PHP.ini memory limit

    I'm trying to install an instance of Moodle 2.0, and am getting this error:
    Sorry, Moodle 2.0 requires at least 70MB of PHP memory.
    Please contact server administrator to fix PHP.ini memory settings.
    I have a reseller account on rs3.abstractdns.com, with cPanel 11.26.9, PHP 5.2.14, MySQL 5.0.91-community. When I access PHP Configuration from cPanel, I see Resource Limits - memory_limit - 32M, but it says these settings are customizable only by the server administrator. I looked for a way to change the PHP settings from WHM, but did not see anything there.

    Should I submit a support ticket to WHB requesting the change, or is there some way I can do this myself?

  2. #2
    Vitaliy K.'s Avatar
    Vitaliy K. is offline WeeHBie
    Join Date
    Apr 2010
    Posts
    567
    Servers
    localhost
    WHB Points this Month
    0.00
    WHB Points
    60.00
    Thanks
    5
    Thanked 4 Times in 4 Posts

    Default

    Hi, you can use local php.ini files to override the server's global php settings.
    In order to increase the memory limit, you need to put a php.ini file to the folder containing your Moodle installation. The file should contain the following text:
    [PHP]
    memory_limit=80M
    You can find more information on the php.ini file in this post.
    Vitalij K.
    Level 2 Technical Team Leader
    WebHostingBuzz.com

    Help WebHostingBuzz today. Like us on Facebook, follow us on Twitter or Google +1 us.
    Visit http://www.webhostingbuzz.com and look for the social media icons at the top of the page.

  3. #3
    dchicago is offline New Bee
    Join Date
    May 2007
    Posts
    2
    WHB Points this Month
    0.00
    WHB Points
    0.00
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Default

    Thanks - that was very helpful.

    I put a php.ini file in the moodle directory, and was able to run the moodle install script. It generated an error message further in, but I fixed that by adding an .htaccess file to apply the php.ini file to subdirectories within the moodle directory. I think it's going to work now.

+ Reply to Thread

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts